KIP Systems Not Affected by Heartbleed

Kip Plotters not affected by Heartbleed Open SSL vulnerability.

Vulnerability due to OpenSSL – Heartbleed

In early April 2014, KIP was advised of the vulnerability known as Heartbleed in an open-source and widely-used Secure Socket Layer toolkit (OpenSSL). The vulnerability allows unauthenticated access to portions of the computer system memory. The code defect has acquired a substantial amount of media attention due to the ease with which the defect can be exploited and the potential exposure to sensitive information.

KIP is pleased to announce that all KIP Print and Scan systems including:

• KIP Print Controllers (PPEC/IPS/KS8)
• KIP Software & Applications
• KIP Drivers
are not affected by this vulnerability.

If you should have any further questions regarding this topic, please contact MBS Business Systems. 

MBS Business Systems is a proud KIP Printer and Plotter authorized dealer. If you are interested in purchasing or leasing a new plotter from MBS, please contact us. One of our business professionals will quickly respond with more information and feedback on any of our copying and printing products and services.

Kip Not Affected by Heartbleed
Kip Plotters not affected by Heartbleed OpenSSL Vulnerability
Share on facebook
Share on twitter
Share on linkedin
Share on email

Help your organization keep up with technology so that you can focus on what's important.

If you’re interested in our solutions, please let us know using this form! Tell us a bit about the problems you’re trying to solve and we’ll reach out to you with information on how we can help!